Geeking Out

Pidgin, Guifications and Glib

I’m having some troubles to install the Guifications plugin for Pidgin. I’ve spent maybe 5 hours looking for a solution but without success so far – and damn it’s getting on my nerves…

I’m running Ubuntu Feisty and Pidgin 2.2.0, both of them running very smoothly. I would like right now to install the Guifications plug-in for Pidgin which is a little system notifying when a user comes online (there are actually many other use cases but this one is for me the most useful). Since there are no Debian packages for this plug-in, I have to compile it from the source which I downloaded on the official website. The only small issue with this method is that I have to download eventual dependencies beforehand.

The problem comes during the configuration (./configure) of the package, at which point I get this (now extremely annoying) error message:


[...]
checking for PIDGIN... yes
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.14.0, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLib 2.0 is required to build Guifications; please make sure you have the
*** GLib development headers installed. The latest version of GLib is always
*** available at http://www.gtk.org/.

If I understand correctly, expected version of Glib is 2.14.0 and the one returned is 2.12.11

I went on (again) to look for the expected version and found it there: http://packages.ubuntu.com/gutsy/libs/libglib2.0-0

I installed all related packages and tried again but without success… Same error message popping up, again and again…

Seeing I can’t get this sorted it out myself, I went to get some help on the official Guification IRC channel where a bunch of bored geeks preferred playing with the moderation bots rather than point me to any relevant resources. Nice.

I posted then on a couple of forums again without much help so far. I have been suggested to install libnotify instead which seems to be a lighter version of Guifications. I will consider this if I can’t get Guifications working :).

Has anyone out there had some similar issue? I would appreciate any kind of help on the matter…

some posts that may be related

5 Comments

speak up

Add your comment below, or trackback from your own site.

Subscribe to these comments.

Be nice. Keep it clean. Stay on topic. No spam.

You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Name*

Email* (Never displayed nor misused!)

Website

Spam protection: Sum of seven + eight ?

*Required Fields